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第一章 ARM7TDMI/LPC2148とは 
■LPC2148は ARM7TDMIコアを使った低消費電力・高速 NXP社のマイコンです。 
■USBターゲットを CPUに内蔵しています。USBを使ったシステムの開発・評価に最適
です。 
■H8や SHと比べると価格も安くて、実にスピードも速い、容量も大きい、消費電力も小
さいです。 
■CPUは 3.3V動作なのですが I/Oポートは 5Vトレラントのため、5V系ロジックを直結
できます。 
■ルネサス SH7144と比べて 
・ スピードは 60MHzなので 20%速い 
・ フラッシュは 512Ｋバイトなので 2倍 
・ RAMは 42Kあるので約 5倍 
・ 消費電力は 60MHzフルスピードで 50mA程度です。約 2～4分の 1です。クロックを
落とせばもっと減ります。 

・ ROMの書き換え回数 10万回、事実上の無制限、データ保持 20年。 
 
 
■LPC2148の主な仕様 
・ ARM7TDMI-S 16/32bit RISCマイコン 
・ FLASH:512Kバイト (H8/3069Fと同じメモリ容量) 
・ RAM:42Kバイト (H8/3069Fの約 2.5倍) ◎ＲＡＭ内蔵の１チップＣＰＵでは最大級 
・ 60MHz動作（12MHzｘ５逓倍） 
・ USB2.0対応インターフェース内蔵（max 12Mbps） 
・ 10ビット ADコンバータ 2ユニット内蔵、14Ch 
・ 10ビット DAコンバータｘ1ｃｈ内蔵 
・ UART(16C550)ｘ2，I2Cｘ2，32ビットタイマｘ2，PWMｘ6，WDT, RTCなど通信系
のインターフェース(SPI/SSP)は 2ch内蔵されています。 

・ 5Vトレラント I/O(ＣＰＵは 3.3V動作ですが、I/Oポートは 5Vの入力を受けられます） 
・ JTAGインターフェース内蔵 
・ Fast I/O機能：通常は CPUコアと I/Oのクロックが異なるため速い CPUコアでも I/O
コントロールにウェイトが入ってしまい、高速に I/Oを操作できません。この LPC2148
では Fast I/O機能により高速に I/Oポートを操作できます。他のＣＰＵの約 3.5倍のス
ピードでポートの操作ができます。 
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第二章 ARM7TDMI/LPC2148開発キット 
 
 
 
 
 
 

電源スイ

ッチ 

USBコネ
クタ(B) 

JTAG ARM7TDMI/LPC2148 

RTC電池
ホルダー

EEPROM
24LC02

COM1 

COM0 

 
 
 
 
 
 
 
 
 
 

AD用のボ
リューム 

5V 電源ソ
ケット 

スピーカ 

ジョイスティック SDソケット(裏)

ユーザー 
ボタン

1.8”TFT液晶 160X128

開発キットのインターフェース 

• RS232(16C550) ×2 
• USB2.0 device ×1 
• JTAG/ICE 
• SDカードソケット 
• ADテスト用のボリューム 
• I2C EEPROM 
• ユーザーLED ×1 
• ユーザーボタン×1 
• ジョイスティック×1 
• スピーカー×1 
• 1.8インチ TFT液晶、分解能 160×128 

外形寸法  

• 外形寸法: 110×70(mm) ※突起物は除く 

供給電源  
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• 5VDC電源、プラグ 2.1mmφ、極性はセンタープラス です。電源スイ

ッチと電源指示 LED付き。USB給電可。 

第三章 初体験 

3.1 デフォルトのサンプル(テトリス) 

 
 
 
 
 
 
 
 
 
 
 
 

ジョイスティック

をやってみます。 

 
 
 
 
 

Example-2148GCC.rar 
は LPC2148開発キットのサンプルです。回路図とソースコードも含みます。な
かのほかのサンプルを体験してみよう。 
 

3.2 書き込みツールのインストール 

FlashMagic とは 
LPC シリーズはフラッシュ ROM を内蔵しているため、ISP（In-System Program）機能
によりユーザ・プログラムを書き込むことができます。そのためのプログラミング・ツー
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ルが FlashMagic です。FlashMagic は次の URL からダウンロードできます。 
 
http://www.flashmagictool.com/
 
FlashMagic.exeを実行すると、LPC2148ボードの書き込みツールをインストールします。
LPC2148の Flashを更新すれば、ほかのサンプルを体験できます。 

 

「Next」ボタンを押すと、英文のライセンスが出てきます。同意できる場合は、「I accept the 
agreement」を選択して、「Next」ボタンを押します。 

http://www.flashmagictool.com/
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インストール先フォルダを変更せず、そのまま進んでください。 
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メニュー・フォルダも変更せず、そのまま進んでください。 

 

そのまま進んでください。 
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インストール前の確認、「install」ボタンを押してください。 

 

インストール中の画面です。 
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最後に「Finish」をクリックすると、ウィザードが閉じてインストールが終了します。 
 

3.3 書き込み 

 
Windows のメニュー「スタート」 「Flash Magic」
「Flash Magic」を選択してください 
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Flash Magicの初画面です。 
 
Flash Magicのメニュー「Options」 「Advanced Options」を選択してください。 
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画面の通りに設定して、「OK」ボタンを押してください。 
 

  

書き込みファイ

ル*.HEXを選択

書き込みボタン 

画面の通りにパラメータを設定して、「Browse」ボタンで書き込みファイル*.hexを選択し
てください。 
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RS232ケーブル 

JP5 をオ
ーペン 

JP8/JP9 を
ショット

書き込みの設定 
書き込みボタン「Start」ボタンを押す前に、LPC2148ボードの JP5/JP8/JP9設定と RS232
ケーブルの接続を確認してください。「Start」ボタンを押すと、書き込み開始 

 
書き込み中の画面です。 
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シリアルポート

を 使 え ば 、

JP8/JP9 をオー
ペン

ボタンとジョイ

スティックを使

えば、JP5 をシ
ョット 

実行の時、JP5/JP8/JP9の設定。 
 

3.4 OpenJTAGで書き込み 

Open-JT G は ARM 用の

エミュレータで

7

ー

A
USB-JTAG
す 。 ARM 、 ARM9 、
Cortex-M3, XSCALEに対応、
OpenOCD をサポ トします。

USB-RS232 機能もあります。
COMと LPTポートがないノ
ートパソコンに最適。 
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PC2148モ で書き込みしかでき

せん。 

JTAGポート

Open-JTAG 

USBシリアル
ケーブルとし

て使えます。 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
L ジュールはシリアルポートがありませんので、open-JTAG
ま
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3.5 OpenJTAGのドライバをインストールする 

OpenJTAG をパソコンの USB ポートに挿入して、下の通りにドライバをインストールし
てください。 
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USB ドライバのインストールは３回があります。インストール完了すると、デバイスマネ
ージャで三つのデバイスが見えます。 
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※ OpenJTAGは USBシリアルポートとして使えます。 
 
 

3.6 OpenOCDのダウンロードとインストール 

1) 下記のリンクをクリック 
http://developer.berlios.de/project/showfiles.php?group_id=4148
 
2）"openocd-0.1.0.msi"をクリック 
    

http://developer.berlios.de/project/showfiles.php?group_id=4148
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３）リンクの DownloadをクリックしWindows用インストーラパッケージをダウンロード
する 

 
５）動作確認のため下記を実行します 
  １．Open-JTAGをターゲット(LPC2148基板)とＰＣに接続 
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  ２．ターゲットに電源を入れます 
  ３．コマンドプロンプトでディレクトリを移動 
     （cd Example-2148GCC¥open-jtag) 
  ４．下記のコマンドを入力します 
     （openocd -f open-jtag.cfg –f lpc2148.cfg） 
  画面のように"Info : JTAG Tap/device matched"と表示されればＯＫです 
    （この時点で ARM LPC2148と通信が出来ています） 
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3.7 telnetで書き込み 

 
新コンソールで telnet localhost 4444コマンドを入力します。telnetで下記のコマンドを
入力します。 

halt               ターゲットを停止 
flash write_image erase Tetris.hex ihex     *.hexファイルを書き込み 
resume 0          実行 
exit               telnetをクロス 
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3.8 GCCサンプルの紹介 

1. LED    LED点灯 
2. GPIO-IN   入力実験 
3. PWM   PWMで LCDのバックライトを点灯 
4. LCD    LCDで英語を表示 
5. LCD-Japanese  日本語を表示 
6. LCD_BMP   ピクチャを表示 
7. RTC    RTC実験 
8. IIC    IICの EEPROMのライト・リード 
9. ADC    ADC実験 
10.DAC   DAC実験 
11.UART_FIFO  UARTのポーリング 
12.UART_INT   UARTの割り込み 
13.Timer0-INT   タイマーの割り込み 
14.EXTINT   外部の割り込み 
15.AD_INT   ADCの割り込み 
16.Sound   DACで音声 
17.SD-FatFs   SDメモリのデモ 
18.USBtarget 
 examples/msc.hex LPC2148経由 SDメモリが USBメモリとして 
 examples/serial.hex LPC2148が USBシリアルポートとして使える 
 ドライバは USBtarget/examples/usbser.infです。 
19.IAP    プログラムで Flashを更新 
20.Webserver   ウェブサーバ、イーサネット ENC28J60用 
21.Tetris   デフォルトのサンプル(テトリス) 
22.nRF24L01   微弱無線モジュール(nRF24L01)の通信実験 
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3.9 USBダウントローダ 

 

 

 

 

 

 

 

 

LPC2148 モジュールには USB ダウンローダが書き込まれています。パソコン上で開発し
たユーザ・プログラムを USB経由で LPC2148のフラッシュ・メモリに書き込むことがで
きます。 

USB ダウンローダ領域は

0~0x1FFFF、ユーザ・プログ
ラム領域は 0x2000 からです。 
 
USB ダウンローダはソース
も含めて公開されています。

Example/USB ISPはUSBダ
ウンローダのプロジェクトで

す。 
 
こ の 仕 組 み に よ っ て

LPC2148 モジュールは、
JTAG デバッグがなくても

USB 経由でアプリケーショ
ン・プログラムの書き換えが可能です。ユーザはパソコンと LPC2148 モジュールだけで
ARMプロセッサのシステムを開発できます。 

24ピン 

書き込む様子 

52ピン

パソコンを繋ぐ

USBケーブル
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誤って 0番地に上書きすると、USBブートローダ壊れてしまうので、注意が必要です。こ
の修復には JTAGデバッグが必要になります。 
 
LPC2148モジュールが起動の時、裏面の拡張ヘッダの 24,52ピンをショットすれば、USB
ダウンローダモードに入ります。 

 
パソコンは LPC2148モジュールを USBメモリとして認識します。LPC2148の USBメモ
リに「firmware.bin」というファイルがあります。サイズは 492KBです。このファイルは
ユーザが使える FlashROMのイメージです。使えるサイズは 492KBです。 
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ユーザ・プログラムを書き換える手順： 
まず、「firmware.bin」というファイルを削除してください。 

 

ユーザ・プログラムのイメージファイル*.binを USBメモリにコピーしてください。 

 
LPC2148の拡張ヘッダの 24,52ピン間の短絡線を外して再起動すると、ユーザ・プログラ
ムを実行します。 
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第四章 クロス開発環境 

4.1 GCCツールチェーン 

各種ユーティリティ： 
http://www.yagarto.de/download/yagarto/yagarto-tools-20070303-setup.exe
 
GCCツールチェーン 
http://sourceforge.net/projects/yagarto/files/YAGARTO%20for%20Windows/yagarto-bu-
2.19.1_gcc-4.3.3-c-c%2B%2B_nl-1.17.0_gi-6.8.50_20090329.exe/download
 
インストールが出来たら make の確認をするためコマンドプロンプトを起動し、右記のコ
マンドを入力します(make --version)。画面に下記のメッセージが出てくればＯＫです。 

 

 
 

http://www.yagarto.de/download/yagarto/yagarto-tools-20070303-setup.exe
http://sourceforge.net/projects/yagarto/files/YAGARTO for Windows/yagarto-bu-2.19.1_gcc-4.3.3-c-c%2B%2B_nl-1.17.0_gi-6.8.50_20090329.exe/download
http://sourceforge.net/projects/yagarto/files/YAGARTO for Windows/yagarto-bu-2.19.1_gcc-4.3.3-c-c%2B%2B_nl-1.17.0_gi-6.8.50_20090329.exe/download
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サンプルのコンパイル： 
1．コマンドプロンプトでディレクトリを移動 
     （cd Example-2148GCC¥1. LED) 
2．下記のコマンドを入力します 
     （make） 

 

コンパイル成功したら、*.hex ファイルを生成させます。生成された*.hex ファイルを
LPC2148に書き込みましょう。 
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4.2 Integrated Development Environment(Eclipse) 
 
JREバージョン確認： 
確認コマンド： java -version 

 

JREがなければ、あるいは 1.4.2以下なら、JREのインストールが必要です。 
http://java.sun.com/javase/downloads/index.jsp
 
 
Eclipseのインストール： 
１）下記のリンクをクリック 
http://www.eclipse.org/downloads/index.php
 
２）Eclipse IDE for C/C++ Debelopers(79MB)のWindowsをクリック 

http://java.sun.com/javase/downloads/index.jsp
http://www.eclipse.org/downloads/index.php
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３）画面の下矢印をクリックしダウンロード 

 
 
４）ダウンロードしたファイル "eclipse-cpp-galileo-win32.zip"を解凍し、そのなか
の”eclipse"フォルダを適当な場所(C:¥eclipse)へ移動する。 
 
5）Eclipseを起動する。 
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６）最初にWorkspaceの場所を聞いてきます。適当なフォルダに変更してください。 

 
 
画面のWorkbenchをクリックします。 
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4.3 プロジェクトを作る 

新規プロジェクトを作成するため"File"→"New"→"C Project"を選択します 
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プロジェクト名を聞かれるので適当な名前(LED)を入力し Finishボタンを押します。 
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Project Explorerにプロジェクト LEDが追加されましたが中身が何もないので、"×"がつい
ています。 

 

サ ン プ ル の フ ォ ル ダ Example-2148GCC¥1. LED の な か の フ ァ イ ル を

"C:¥workspace¥LED"にコピーしてください。 
 
Eclipseの”File"→"Refresh"を選択します。 
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Project Explorer の"LED"プロジェクトの左にある＋をクリックするとファイルの一覧が
表示されます。 

 
 

4.4 Eclipseプラグイン(Zylin Embedded CDT)インストール 

Eclipseの"Help"→"Install New Software"を選択します 
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Addボタンを押します。 

 
Add Siteの"Location"に"http://opensource.zylin.com/zylincdt "と入力しOKボタンを押す。 
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Install に"http://opensource.zylin.com/zylincdt "が追加されるのでチェックボックスにク
リックしチェックを入れて Nextボタンを押す。 
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インストール完了したら、Yesボタンを押して、Eclipseを再起動させます。 
 

4.5 ビルドの設定 

Eclipseの"Project"→"Preferences"を選択する。 
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Preferencesの"Build"を選択し"Scanner Configuration Builder"のチェックマークを外し
て 
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Preferences の "C/C++ Build"→"Settings"を選択し"Binary Parsers"タブの"GNU Elf 
Parser"にチェックを入れて OKボタンを押します 
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4.6 ビルド 

Eclipseの"Project"→"Build Automatically"のチックを外してください。 

 
 
 
"Project"→"Clean"を選択するクリアが行われます。 
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「Start a build immediately」のチェックマークを外して、「Ok」を押します。 
 
"Project"→"Build All"を選択するとビルドが行われます。 
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コンパイル中です。 

 

コンパイルが成功すれば、実行ファイル LED.elfと LED.hexを生成されます。 
 

4.7 GDBの設定 

Eclipseの"Run"→"Debug Configurations..."を選択します。 
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Debug Configurationsの"Zylin Enbedded debug(Native)"を右クリックし"New"を選択す
る。 
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Nameに適当な名前を入れる。例、"gdb"と入れます。Mainタブの"Project"に"LED"、"C/C++ 
Appication:"に"C:¥workspace¥LED¥LED.elf"と入力します。 
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Debuggerタブの"GDB debugger:"に"arm-elf-gdb"、"GDB command file:"に何も入力しま
せん。 
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Commands タブの"'Initialize' commands"に下記の画面の様に入力します 

target remote localhost:3333 

monitor halt 

monitor step 

load 

break main 

continue 

 
 
Commonタブの"Display in favorites menu"の Debugにチェックを入れます。全てを入力
し終えたら"Apply"ボタンを押し、"Close"ボタンを押します。 
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全てを入力し終えたら"Apply"ボタンを押し、"Close"ボタンを押します。 
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4.8 OpenOCDの設定 

Eclipseの"Run"→"External Tools."→"External Tools Configrurations..."を選択します。 
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External Tools Configrurationsの"Program"を右クリックし、"New"を選択します。 
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Mainタブの"Name"に適当な名前を入力してください。私は”OpenOCD"と入れました。 
"Location:"に"C:¥Program Files¥OpenOCD¥0.1.0¥bin¥openocd"、 
"Working Directory:"に"C:¥Example-2148GCC¥open-jtag"、 
"Arguments:"に-f open-jtag.cfg -f lpc2148.cfgと入力します。 
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Buildタブをクリックし"Build before launch"にチェックを外れます。 
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Commonタブをクリックし"Display in favarites menu"の"External Tools"にチェックを入
れます。全てを入力し終えたら"Apply"ボタンを押し、"Close"ボタンを押します。 
 

4.9 デバッグ 

電源投入 
1. OpenJTAGをターゲット(LPC2148ボード)とパソコンに接続 
2. ターゲットに電源を入れます 
 



株式会社日昇テクノロジー 
 

ホームページ：http://www.csun.co.jp         メール：info@csun.co.jp  58 

External Toolsの▼ボタンをクリックし、OpenOCDを選択 

 
Consoleウインドに下記のメッセージが出力 

 

 
Debugの▼ボタンをクリックし、"gdb"を選択。 
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Yesボタンを押して、デバッグが開始します。 
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Eclipseに Debug用のコマンドあるいはショットカット一覧 
詳しくは Eclipseのドキュメントを参照 

 
 

ステップ実行において良く使われる操作の一覧を以下に示します。 

  

操作名 ショートカットキー 

再開 F8 

ステップイン F5 

ステップオーバー F6 

ステップ・リターン F7 

  

  

ステップ実行とは関係ありませんが、前回起動したクラスを再度実行したデバッグする場合は、

以下のショートカットキーが便利です。 

  

操作名 ショートカットキー 

前回の起動を実行 Ctrl + F11 

前回の起動をデバッグ F11 

 

ブレークポイントでプログラムが中断した状態から、次のブレークポイントまで実行させ

たり、1行ずつ実行させたりできます。コードを繰り返して実行することにより、LEDラン

プが点滅します。 
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ダブルクリックで breakpointを設置/キャンセルします。 

 

4.10 デバッグ終了 

１）gdbの停止 
  Debugウインドウの gdbの Threadを選択し、停止ボタンと押します 

 
２）OpenOCDの停止 
  Debugウインドウの OpenOCDの Threadを選択し、停止ボタンと押します 
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３）電源停止 
  ターゲットの電源を停止 
 
４）OpenJTAGをターゲットから取り外す 
 
５）上記が面倒であれば Eclipse を終了しターゲットの電源停止、open-JTAG を取り外し
でも OKです。 
 
 

※ ほかのサンプルは Example-2148GCC.rar
を参照してください。 
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第五章 SPIイーサネットモジュール ENC28J60 
MICROCHIP 社から ENC28J60 という、SPI 接続のイーサネットコントローラ
(MAC+PHY)が発売されました。10BASET-Tですので、速度は早くありませんが、SPIイ
ンターフェイスでマイコンと接続できるのが特徴です。 

SPI インターフェイスは、SO、SI、SCK、CS の
４本で構成され、速度も ENC28J60 の場合は
8MHz-10MHz でマイコンと接続することが出来
ます。SPI は AVR、PIC、ARM、H8 などのマイ
コンに標準的なインターフェイスですので、手軽

にマイコンと接続出来ます。10BASET-T のイーサ
ネットコントローラとしては RTL8019AS などが
有名ですが、こちらはデータバス接続となります

ので、２０本近くの配線が必要になりますので、

ピン数の少ないマイコンには荷が重過ぎます。 
 

 

+ 
 
 

= 
ENC28J60 

LPC2148モジュール 
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ホ

サンプル： WebServer/WebServer.bin 
 
 
このサンプルを LPC2148モジュ
ールにダウンロードして、パソコ

ン の ブ ラ ウ ザ ー で URL
「 http://192.168.3.250/csun.co.j
p」を入力すると 
 
 
 

 
 
 
 
 
 
 
 
サンプルの IPアドレスとパスワードがWebServer.cにあります。自分のネットワークによ
って直してください。 
WebServer.c 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

～ (略) ～ 
 
static uint8_t mymac[6] = {0x54,0x55,0x58,0x10,0x00,0x24}; 
// how did I get the mac addr? Translate the first 3 numbers into ascii is: TUX 
static uint8_t myip[4] = {192,168,3,250}; 
// listen port for tcp/www (max range 1-254) 
#define MYWWWPORT 80 
// 
// listen port for udp 
#define MYUDPPORT 1200 
 
#define BUFFER_SIZE 1500//450 
static uint8_t buf[BUFFER_SIZE+1]; 
 
// the password string (only the first 5 char checked), (only a-z,0-9,_ characters): 
static char password[]="csun.co.jp"; // must not be longer than 9 char 
 
～ (略) ～ 
ームページ：http://www.csun.co.jp         メール：info@csun.co.jp  64 
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第六章 USBで ARM9(Linux)に接続 
弊社の ARM9(MINI2440)は標準 OSに Linuxを採用します。Linuxには、信頼性が高いネ
ットワークスタックが実装され、利用できます。従って、ネットワークに接続する信頼性

の高い遠隔制御機器が、容易に作成できる利点があります。Linuxにも USBスタックが実
装され、多種類のUSBデバイスを利用できます。例えば、USBプリンター、USB無線LAN、
USBメモリ、SDカードなど。パソコンの Linux上のアプリケーションが ARM9上で利用
できます。ゼロから開発せずに、例えば GUIとWebサーバなどが組み込み用機器で利用で
きるわけで、これは非常に大きな利点といえます。 
 
Linuxの便利さの反面、複雑、重い、反応速度が遅いです。反応速度は大体数十msぐらい
です。この反応速度は人間との会話に満足できますが、機械制御のリアルタイム性に足り

ないかもしれません。 
 
ARM7シリーズはリアルタイム制御に向けのマイコンです。OSなしあるいは簡単な RTOS
を搭載します。1us~1ms以上の反応速度が実現できます。ARM7は制御のため、豊富な制
御用の周辺機能を持ちます。例えば AD, DA, PWM, GPIO, カウンターなど。 
 
ARM7/LPC2148にはUSBターゲットポートがあります。最大通信速度 12Mbps。LPC2148
は USB デバイスとして使えます。ARM9 は USB ハブを経由すれば、何台分の LPC2148
にも接続できます。拡張性がいいです。パソコンも LPC2148デバイスを使えます。 
 
システムは ARM9/MINI2440と ARM7/LPC2148を同時に採用すれば、Linuxの便利な機
能と ARM7のリアルタイム性を組み合わせ、高度複雑なアプリケーションとリアルタイム
制御が両立できるシステムを作れます。 
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DI 

D/A 

DO 

A/D 

インターフェース

ボード 

…… 

ARM7/LPC2148 ARM7/LPC2148  
 

USB ハブを経由す
れば、何台分のイン

ターフェースボー

ドに接続できます。

…… 

USBハブ

 
 
 
 
 
 
 
 
 

 

写真はMINI2440と LPC2148を USBで繋ぐ様子。 
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LPC2148は CDC ACMデバイスとして動きます。ARM9側から見ると、LPC2148は USB
シリアルポートです。ARM9のターミナルで下のコマンドを入力 
# armcomtest –d /dev/ttyACM0 
 
キーボードで情報を入力します。ARM9はこの情報をARM7へ送信します。ARM7はARM9
が送った情報をそのまま ARM9へ返信します。ARM9はこの情報をコンソールで表示しま
す。 

LPC2148側のサンプルはUSBtarget/examples/serial.hex で

す。 
 
ARM9の Linuxのコンフィグの手順： 
下のコマンドで Linuxのコンフィグに入ります。 
$ cd linux-2.6.29 
$ make clean 
$ cp config_mini2440_n35 .config 
$ make menuconfig 

 
「Device Drivers」を選択、 
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「USB support」を選択、 

 
「USB Modem(CDC ACM) support」を選択します。“Exit”&“Save”します。 
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下のコマンドで Linuxカーネルをコンパイルします。 
$ make zImage 
 
コンパイル完了すれば、arch/arm/boot フォルダには CDC ACMを含むカーネル zImage
を生成します。この zImageファイルを ARM9に書き込んでください。詳しい情報は ARM9

のマニュアルをご参照ください。 

 

第七章 微弱無線モジュール nRF24L01(2.4GHz) 

 

弊社が販売している微弱無線モジュール nRF24L01(2.4GHz) 

• Nordic Semiconductor 社の NRF24L01 を搭載  

• 最大伝送速度: 2Mbps、VoIP 応用可能  

• 使用周波数帯: 2.4GHz ISM 帯  

• 変調方式: GFSK  

• 定格電圧: 1.9～3.6V  

• SPI インターフェース  

• 使いやすい 2.54mmDIP  

nRF24L01モジュールと LPC2148モジュールの接続： 
nRF24L01 LPC2148モジュール nRF2401 LPC2148モジュール

1. GND 26. GND 2. VCC 52. 3.3V 

3. CE 43. P1.24 4. CSN 9.  P0.7(SSEL0) 

5. SCK 6.  P0.4(SCK0) 6. MOSI 8.  P0.6(MOSI0) 

7. MISO 7.  P0.5(MISO0) 8. IRQ 44. P1.25(EXTIN0) 

※ 始めの数字はモジュールのピン番号です。 
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受信指示 LED：LPC2148モジュールの PIN34(P0.31)と PIN27(VBAT/3.3V) 

 

8ピン配列
変換ケーブ

nRF24L01
モジュール 

LPC2148 
モジュール 

受信指示 
LED 

送信用のプログラム：nRF24L01/ send.bin 

受信用のプログラム：nRF24L01/ rev.bin 
この実験は二つのセット(LPC2148+nRF24L01)が必要です。一つは送信です。もう一つは受

信です。送受信成功すれば、受信指示 LEDが点滅します。 
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